#TIL #linux apt-get으로 특정 버전 패키지 설치

$ sudo apt-get update

최신 패키지 정보로 캐시를 업데이트한다

$ apt-cache policy mysql-server
mysql-server:
  Installed: (none)
  Candidate: 5.7.24-0ubuntu0.16.04.1
  Version table:
     5.7.24-0ubuntu0.16.04.1 500
        500 http://kr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://kr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
     5.7.11-0ubuntu6 500
        500 http://kr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://kr.archive.ubuntu.com/ubuntu xenial/main i386 Packages

apt-cache policy 명령으로 설치된 버전과 설치할 수 있는 버전을 찾는다.

$ sudo apt-get install mysql-server=5.7.24-0ubuntu0.16.04.1

[package]=[version] 형식으로 설치할 패키지 이름과 버전을 지시할 수 있다

참고

Feedback plz <3 @ohyecloudy, ohyecloudy@gmail.com


|