#TIL #xcode #vim 지원 플러그인 xvim

Since Apple decided not to load 3rd party plugins, we have to make change to it. What we have to do overall is to re-codesign Xcode. This allows us to load 3rd party plugins. Here’s the steps to do.

- Install XVim for Xcode 8

플러그인 좀 쓰게 해주지. xcode 8에서는 그냥 못 쓴다.

$ time sudo codesign -f -s ohyecloudy /Applications/Xcode.app
Password:
/Applications/Xcode.app: replacing existing signature

real    9m18.128s
user    3m9.576s
sys    2m46.899s

그냥 못 쓰고 코드 사인을 다시 해야 한다. 배포에는 문제가 생기지 않을까? 몰라. 시간이 지나면 해결되겠지. 아니면 배포용 빌드를 만들 때, xcode를 한 벌 더 설치해야 한다.

망했어. vim 키바인딩이 없으면 아무것도 못 하겠다.

링크

Feedback plz <3 @ohyecloudy, ohyecloudy@gmail.com
|